diff options
author | Josh Triplett <josh@joshtriplett.org> | 2020-08-27 10:45:51 -0700 |
---|---|---|
committer | GitHub <noreply@github.com> | 2020-08-27 13:45:51 -0400 |
commit | 933eb8ab38317d894b8b09b4de3cecd317221e06 (patch) | |
tree | 5e0d48dbf2043dad60a8900061ac921745133093 /Cargo.toml | |
parent | dd7596758f55fcbbfbd690a8da17d8a17c4ec1d8 (diff) |
Switch from error-chain to thiserror (#33)
thiserror provides a simpler interface than error-chain, directly
generating an error enum similar to what could be written by hand. It
also reduces dependencies; error-chain pulls in backtrace which
currently pulls in gimli, which is fairly heavyweight.
This changes the error type's interface, so it'll require a bump to
0.7.0.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -19,10 +19,10 @@ repository = "samscott89/serde_qs" [dependencies] actix-web = { version = "2.0", optional = true } data-encoding = "2.2.1" -error-chain = "0.12.2" futures = { version = "0.3", optional = true } percent-encoding = "2.1.0" serde = "1.0.111" +thiserror = "1.0.20" [dev-dependencies] csv = "1.1.3" |