summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJesse Morgan <jesse@jesterpm.net>2020-09-18 09:22:03 -0700
committerJesse Morgan <jesse@jesterpm.net>2020-09-18 09:22:03 -0700
commit89734a74faed3c330bed569ac36b6480da8ed8d9 (patch)
tree278b74f181e2866a439720f69c9d9b5699276c03 /Cargo.toml
parent001d2d3dccafea7b368cd6545a5a0b000a84ee76 (diff)
First pass at a photo resizing endpoint.
This is currently fetching the images from the media_url, since I ripped it out of another project. I still need to change it to fetch from S3 directly. This is also using actix_web::client instead of reqwest. I should probably switch the oauth module to do the same.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 584e0f5..e076570 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,8 @@ log = "0.4"
actix-multipart = "0.2"
actix-rt = "1.0.0"
-actix-web = "2.0.0"
+actix-web = { version = "2.0.0", features = ["openssl"] }
+bytes = "0.5"
futures = "0.3"
chrono = { version = "0.4", features = ["serde"] }
@@ -26,3 +27,4 @@ reqwest = { version = "0.10", features = ["json"] }
rusoto_core = "0.45.0"
rusoto_s3 = "0.45.0"
+image = "0.23"