summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJesse Morgan <jesse@jesterpm.net>2018-04-16 20:17:51 -0700
committerJesse Morgan <jesse@jesterpm.net>2018-04-16 20:17:51 -0700
commit43ee6c4887a0c51f935656e829b8a57c6079ebb7 (patch)
tree6211216b0f3c2aa88a6e8041b03801958a2ad9b1 /setup.py
First pass at tagging and report functions.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..6a393bc
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+
+from setuptools import setup, find_packages
+setup(
+ name="ugbudget",
+ version="0.1",
+ packages=find_packages(),
+
+ install_requires=['gnucashxml >= 1.0'],
+
+ author="Jesse Morgan",
+ author_email="jesse@jesterpm.net",
+ description="Usable Gnucash Budget Tools is a collection of tools to make budgeting with GnuCash simpler.",
+ license="MIT",
+ keywords="gnucash budget",
+
+ entry_points={
+ 'console_scripts': [
+ 'ugbudget = ugbudget.ugbudget:main'
+ ],
+ }
+)