summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ad417fa..5f4336d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -22,6 +22,7 @@ serde = "1.0"
thiserror = "1.0"
tracing = { version = "0.1", optional = true }
warp-framework = { package = "warp", version = "0.3", default-features = false, optional = true }
+axum-framework = { package = "axum", version = "0.5", default-features = false, optional = true }
[dev-dependencies]
csv = "1.1"
@@ -38,6 +39,7 @@ actix2 = ["actix-web2", "futures"]
# deprecated feature -- used to return a warning
actix = []
warp = ["futures", "tracing", "warp-framework"]
+axum = ["axum-framework", "futures"]
[package.metadata.docs.rs]
features = ["actix4", "warp"]