summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7307e69..e9803e7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,7 +17,8 @@ version = "0.7.2"
repository = "samscott89/serde_qs"
[dependencies]
-actix-web = { version = "2.0.0", optional = true }
+actix-web = { version = "3.3", optional = true }
+actix-web2 = { package = "actix-web", version = "2.0.0", optional = true }
data-encoding = "2.3.1"
futures = { version = "0.3.8", optional = true }
percent-encoding = "2.1.0"
@@ -33,7 +34,7 @@ serde_urlencoded = "0.7.0"
[features]
default = []
actix = ["actix-web", "futures"]
+actix2 = ["actix-web2", "futures"]
[package.metadata.docs.rs]
features = [ "actix" ]
-all-features = true