diff options
author | Omid Rad <omid@users.noreply.github.com> | 2022-03-05 23:11:59 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2022-03-05 17:11:59 -0500 |
commit | d4c2caa53736ada8cd78e256fb95019b79e74bf7 (patch) | |
tree | 38950f972c074b8106c9306f57246e5bdd723b07 /Cargo.toml | |
parent | 7addf2f16ad68988e2125677de931b1bade2f9d1 (diff) |
Actix 4 (#56)
* Remove all default actix features
* Set MSRV
* Have `actix4` feature, instead of `actix`
* enable actix tests for all features
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 11 |
1 files changed, 7 insertions, 4 deletions
@@ -10,10 +10,12 @@ name = "serde_qs" repository = "https://github.com/samscott89/serde_qs" readme = "README.md" version = "0.8.5" +rust-version = "1.36" [dependencies] -actix-web = { version = "3.3", optional = true, package = "actix-web", default-features = false } -actix-web2 = { package = "actix-web", version = "2.0", optional = true, default-features = false } +actix-web4 = { version = "4.0", optional = true, package = "actix-web", default-features = false } +actix-web3 = { version = "3.3", optional = true, package = "actix-web", default-features = false } +actix-web2 = { version = "2.0", optional = true, package = "actix-web", default-features = false } futures = { version = "0.3", optional = true } percent-encoding = "2.1" serde = "1.0" @@ -30,9 +32,10 @@ serde_with = "1.10" [features] default = [] -actix = ["actix-web", "futures"] +actix4 = ["actix-web4", "futures"] +actix3 = ["actix-web3", "futures"] actix2 = ["actix-web2", "futures"] warp = ["futures", "tracing", "warp-framework"] [package.metadata.docs.rs] -features = ["actix", "warp"] +features = ["actix4", "warp"] |