summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSam Scott <sam.scott89@gmail.com>2019-01-23 12:06:41 -0500
committerSam Scott <sam.scott89@gmail.com>2019-01-23 12:06:41 -0500
commit30c3802305fab702c1704091013c5af874997c01 (patch)
tree41bd13460f5752caed77ec459efe9264b1629e24 /Cargo.toml
parent3fe8fc3dc024cf46c25223ce3f8fb7bcbfb15547 (diff)
Add feature for easy use in `actix_web` extractors.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3248bea..c9aec34 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,6 +16,7 @@ version = "0.4.4"
repository = "samscott89/serde_qs"
[dependencies]
+actix-web = { version ="0.7", optional = true }
data-encoding = "2.1.2"
error-chain = "0.12.0"
percent-encoding = "1.0.1"
@@ -27,11 +28,10 @@ rand = "0.6.4"
serde_derive = "1.0.85"
serde_urlencoded = "0.5.4"
-[lib]
-test = false
+[features]
+default = []
+actix = ["actix-web"]
-[profile]
-
-[profile.release]
-debug = true
-lto = false
+[package.metadata.docs.rs]
+features = [ "actix" ]
+all-features = true