summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJorgen Schaefer <forcer@forcix.cx>2012-10-30 11:40:57 +0100
committerJorgen Schaefer <forcer@forcix.cx>2012-10-30 11:40:57 +0100
commit70d0ad532dd7e8bfa3e3583f2b4ea3a98f40af02 (patch)
tree5c10003d25e3f17d23733bd0dd994cd7e3004515 /setup.py
parent513e37286d9a37dd29e99220bfb996785c793333 (diff)
distutils support for pypi. Also add copyright notice.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..5773188
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,16 @@
+#!/usr/bin/env python
+
+import shutil
+
+from distutils.core import setup
+
+shutil.copy("README.md", "README.txt")
+
+setup(name='gnucashxml',
+ version='1.0',
+ description="Parse GNU Cash XML files",
+ author="Jorgen Schaefer",
+ author_email="forcer@forcix.cx",
+ url="https://github.com/jorgenschaefer/gnucashxml",
+ py_modules=['gnucashxml']
+ )