summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..3478efb
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "flowerpot"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+dotenv = "0.15"
+env_logger = "0.7"
+log = "0.4"
+
+actix-files = "0.2.2"
+actix-rt = "1.0.0"
+actix-web = { version = "2.0.0", features = ["openssl"] }
+
+thiserror = "1.0"
+anyhow = "1.0"
+
+chrono = { version = "0.4", features = ["serde"] }
+
+serde = { version = "1.0", features = ["derive"] }
+serde_json = "1.0"
+
+# diesel = { version = "1.4.4", features = ["sqlite", "extras"] }
+diesel_migrations = { version = "^2.0.0", git = "https://github.com/diesel-rs/diesel/"}
+diesel = { version = "^2.0.0", features = ["sqlite", "chrono"], git = "https://github.com/diesel-rs/diesel" }
+
+hmac = "0.12"
+sha2 = "0.10"
+urlencoding = "2.1"
+hex = "0.4"