summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJesse Morgan <jesse@jesterpm.net>2015-10-24 13:28:24 -0700
committerJesse Morgan <jesse@jesterpm.net>2015-10-24 13:28:24 -0700
commit95ee2046715024e7eedf663e09161933689a7aef (patch)
tree9a0bf8dfaa91ef97f24671a53d51d0829ce2a48f /setup.py
Initial commit.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..bc53c06
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+#!/usr/bin/env python
+from setuptools import setup, find_packages
+
+setup(name='emailcanary',
+ version='0.1',
+ author='Jesse Morgan',
+ author_email='jesse@jesterpm.net',
+ url='https://jesterpm.net',
+ download_url='http://www.my_program.org/files/',
+ description='Email Canary sends emails to a distribution list and checks for proper distribution.',
+
+ packages = find_packages(),
+ include_package_data = True,
+ exclude_package_data = { '': ['README.txt'] },
+
+ scripts = ['bin/emailcanary'],
+
+ license='MIT',
+
+ #setup_requires = ['python-stdeb', 'fakeroot', 'python-all'],
+ install_requires = ['setuptools'],
+ ) \ No newline at end of file