From 6429b975c6cbcf5d7e0c2b1d02026f8d46b5c50f Mon Sep 17 00:00:00 2001
From: Sam Scott <sam.scott89@gmail.com>
Date: Sun, 21 May 2017 16:08:51 +0100
Subject: Stop LevelDeserializer from coercing values too early.

When deserializing types such as TupleStructs, if the `Level`
value is a map, let's call `visit_map` instead of coercing it
to a sequence immediately.
---
 Cargo.toml | 1 +
 1 file changed, 1 insertion(+)

(limited to 'Cargo.toml')

diff --git a/Cargo.toml b/Cargo.toml
index e4f3af7..da6c987 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,6 +27,7 @@ url = "1.0.0"
 [dev-dependencies]
 csv = "0.15"
 rand = "0.3"
+serde_json = "1.0.2"
 serde_urlencoded = "0.4"
 
 [lib]
-- 
cgit v1.2.3