summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 10 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3b296e0..38467a2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,5 +1,6 @@
[package]
authors = ["Sam Scott <me@samjs.co.uk>"]
+edition = "2018"
categories = ["encoding", "web-programming"]
description = "Querystrings for Serde"
documentation = "https://docs.rs/serde_qs"
@@ -8,7 +9,7 @@ license = "MIT/Apache-2.0"
name = "serde_qs"
repository = "https://github.com/samscott89/serde_qs"
readme = "README.md"
-version = "0.5.1"
+version = "0.6.0"
[badges]
@@ -16,21 +17,22 @@ version = "0.5.1"
repository = "samscott89/serde_qs"
[dependencies]
-actix-web = { version ="1.0.0", optional = true }
-data-encoding = "2.1.2"
-error-chain = "0.12.0"
+actix-web = { version = "2.0", optional = true }
+data-encoding = "2.2.1"
+error-chain = "0.12.2"
+futures = { version = "0.3", optional = true }
percent-encoding = "2.1.0"
-serde = "1.0.85"
+serde = "1.0.111"
[dev-dependencies]
-csv = "1.0.5"
+csv = "1.1.3"
rand = "0.7.3"
-serde_derive = "1.0.85"
+serde_derive = "1.0.111"
serde_urlencoded = "0.6.1"
[features]
default = []
-actix = ["actix-web"]
+actix = ["actix-web", "futures"]
[package.metadata.docs.rs]
features = [ "actix" ]